Product Support

Product Support
A description has not yet been added to this group.

SSD not showing up in "my computer"

  • I just installed an 80GB SSD in my DX58SO , extreme system today. It's not showing up in " my computer "  Below are the symptoms and what I have checked. Hopefully someone here has experienced this before.


    1) Drive does not show up in " my computer ".

    2) Shows up in " device manager ", says it's working ok.

    3) Went to Bios " drive configuration " , shows SSD in SATA Port 4.

    4) I booted the system with S.M.A.R.T. enabled and disabled, no help .

    5) the system is a week or so old and everything else about this system is and has been working just fine from the very begining.

    6) My C drive installed is a 1 TB WD and works just fine.


     That's about the " whole story " . At this point I've run out of ideas. I can't see swapping out the drive because all checks say it's ok, it just isn't showing up in " my computer " , it seems to me it's not the fault of the drive, considering everything else ( bios etc ) says it's installed and working properly . One last  thing I'll check is the order that the drives are installed in the ports.

  • I checked the order that my drives are installed in the ports, ( shouldn't matter since these SATA ports are probably in parallel on a buss ) I checked anyway. Boot drive WD 1 TB is on port zero, SDD is on port 1, cd/dvd drives are on ports 2 and 3.

     Intel installation guide says to call them if system doesn't come up after checking the bios, sooo, guess I'll call Intel in the am. The system is supposed to recognize the drive, it's actually doing that , it just doesn't show up in " my computer " . Has anyone else here run into this ? If so what was the fix ?



  • Just a little followup here. I worked with Intel Tech Support , we verified what I already did along with formatting the drive, no help. We then swapped the drive into another computer , same result.

    Intel Tech Support offered me the choice of RMA'ing it to him or Newegg, he suggested Newegg since it would be much faster for me. I am shipping the drive today on RMA to Newegg, I'm just waiting for a shipping label now.


     That's it, thought I would give you the followup and resolution to this problem.




  • Just to verify, you did go into Volume Management and create a partition for this drive, correct?
  • Hi Ra,

                        Yes I/we did that.  

     According to the Intel installation guide or the booklet that came with it Intel said that if the drive didn't "install" to check that is was in the bios, " auto detected " if not to make sure it was shown in the bios and if that didn't solve the problem to call them. Kinda amazing, Intel treating these like they are supposed to be " plug and play ". Anyway, to answer your question I did all of that and then Intel Tech support verified it with me.